Kinook Software Forums

Kinook Software Forums (http://www.kinook.com/Forum/index.php)
-   [VBP] Third Party Tools (http://www.kinook.com/Forum/forumdisplay.php?f=3)
-   -   Visual Build and Hudson (http://www.kinook.com/Forum/showthread.php?t=5093)

Shiamak 10-17-2012 03:10 PM

Visual Build and Hudson
 
Is anyone out there using VisualBuild with Hudson? if yes than could you please share your experiences?

kinook 10-17-2012 06:42 PM

http://www.kinook.com/VisBuildPro/Manual/continteg.htm

Shiamak 10-17-2012 07:17 PM

So that command is enough to drive the build using Hudson and VisualBuild?

kinook 10-17-2012 11:02 PM

It worked in our tests.

Shiamak 06-07-2013 05:34 PM

Hi,

I am getting following error while running the VBP 7 build script with hudson

Started by user anonymous
Building on master
Cleaning the workspace because project is configured to clean the workspace before each build.
[Projects] $ cmd /c call C:\Users\pxa\AppData\Local\Temp\hudson677262359623 2071190.bat

d:\Hudson\Projects>"D:\VisBuildPro7\VisBuildCmd.exe" /b "C:\Build_Scripts\abc_Build.bld"
The system cannot find the path specified.

d:\Hudson\Projects>exit 3
[DEBUG] Skipping watched dependency update for build: SapphireBuilds #43 due to result: FAILURE
Finished: FAILURE

Shiamak 06-07-2013 05:35 PM

path exists cause I tried to run the path

d:\Hudson\Projects>"D:\VisBuildPro7\VisBuildCmd.exe" /b "C:\Build_Scripts\Sapphire_Build.bld"

manually , it worked fine?..any clues?

kinook 06-09-2013 03:11 PM

Hudson is calling abc_Build.bld, while the direct call is calling Sapphire_Build.bld?

Shiamak 06-10-2013 12:31 PM

Sapphire_Build.bld should have been replaced by abc.bld, I didnt want to display sapphire_build.bld..

kinook 06-10-2013 06:53 PM

Not sure, I guess one of those paths is not valid on "master"? The sample command from the Jenkins/Hudson section of http://www.kinook.com/VisBuildPro/Manual/continteg.htm worked properly in my tests on Windows 7 x64 w/ Visual Build Pro 8.4 x64 and Hudson 3.0.1 installed.
Code:

Started by user anonymous
[workspace] $ cmd /c call C:\Users\xyz\AppData\Local\Temp\hudson3147722429993221264.bat

C:\Users\xyz\.hudson\jobs\test\workspace>"C:\Program Files\VisBuildPro8\VisBuildCmd.exe" /b "C:\Program Files\VisBuildPro8\Samples\RegEdit.bld"

VisBuildCmd (x64), Version 8.4.0.0
Copyright (C) 1999-2013 Kinook Software, Inc. All rights reserved.

6/10/2013 5:50:26 PM: Starting Build: 'C:\Program Files\VisBuildPro8\Samples\RegEdit.bld'
6/10/2013 5:50:26 PM: Building project step 'Create Values'...
6/10/2013 5:50:26 PM: Building project step 'Set Default'...
Created Temporary macro 'NUM'
6/10/2013 5:50:26 PM: Building project step 'Create String Value'...
Registry value 'HKEY_CURRENT_USER\Software\Kinook Software\Visual Build Professional 8\Test Key\StringVal' created
6/10/2013 5:50:26 PM: Building project step 'Read int value'...
Reading registry value 'HKEY_CURRENT_USER\Software\Kinook Software\Visual Build Professional 8\Test Key\IntVal'...
Registry value not found, using default
6/10/2013 5:50:26 PM: Building project step 'Show the value of 'IntVal''...
Before, IntVal equals '0'
6/10/2013 5:50:26 PM: Building project step 'Create DWORD Value'...
Registry value 'HKEY_CURRENT_USER\Software\Kinook Software\Visual Build Professional 8\Test Key\IntVal' created
6/10/2013 5:50:26 PM: Building project step 'Read int value again'...
Reading registry value 'HKEY_CURRENT_USER\Software\Kinook Software\Visual Build Professional 8\Test Key\IntVal'...
6/10/2013 5:50:26 PM: Building project step 'Show the update value'...
IntVal now equals '44'
6/10/2013 5:50:26 PM: Building project step 'Delete Values'...
Step 'Delete Values' build rule evaluates false: %DELETE% is defined
6/10/2013 5:50:26 PM: Step skipped
6/10/2013 5:50:26 PM: Building project step 'Del String Value'...
Step 'Delete Values' build rule evaluates false: %DELETE% is defined
6/10/2013 5:50:26 PM: Step skipped
6/10/2013 5:50:26 PM: Building project step 'Del DWORD Value'...
Step 'Delete Values' build rule evaluates false: %DELETE% is defined
6/10/2013 5:50:26 PM: Step skipped
6/10/2013 5:50:26 PM: Build successfully completed (elapsed = 00:00:00).

C:\Users\xyz\.hudson\jobs\test\workspace>exit 0
Finished: SUCCESS

When specifying an invalid exe, I got:

'"C:\Program Files\VisBuildPro8\VisBuildCmdx.exe"' is not recognized as an internal or external command,
operable program or batch file.

When specifying an invalid bld file, I got:

VisBuildCmd (x64), Version 8.4.0.0
Copyright (C) 1999-2013 Kinook Software, Inc. All rights reserved.

Error loading project file: Failed to open 'C:\Program Files\VisBuildPro8\Samples\RegEditx.bld': The system cannot find the file specified.

Both of those are different than your error message, so I'm not sure which path Hudson is complaining about.

Shiamak 06-10-2013 07:02 PM

It works for me now, I am not really sure what made it work...I didnt change anything just rebooted my windows server.

Thanks for your prompt reply...


All times are GMT -5. The time now is 02:25 AM.


Copyright 1999-2019 Kinook Software, Inc.