Kinook Software Forums

Kinook Software Forums (http://www.kinook.com/Forum/index.php)
-   [VBP] Third Party Tools (http://www.kinook.com/Forum/forumdisplay.php?f=3)
-   -   PowerShell 6 and 7 support (http://www.kinook.com/Forum/showthread.php?t=5650)

mevans 05-04-2020 12:57 PM

PowerShell 6 and 7 support
 
I've only used PowerShell 5.1 and below with Visual Build. The recent release of PowerShell 7 is supposed to have more backward compatibility with PowerShell 5.1 and below, so I'm considering trying it out.

Does Visual Build support running PowerShell 6 or 7 scripts? If so, what is the recommended approach? I guess if nothing else, I could try overriding the executable in the options tab, but I want to see if you have a recommendation.

kinook 05-04-2020 10:47 PM

It does now, in the latest download (VisBuildCore.dll 10.2.0.1). For the v7.1 preview, you will need to specify the path to pwsh.exe in the Override field on the Options tab.


All times are GMT -5. The time now is 03:37 AM.


Copyright 1999-2019 Kinook Software, Inc.