Kinook Software Forums

Kinook Software Forums (http://www.kinook.com/Forum/index.php)
-   [VBP] Third Party Tools (http://www.kinook.com/Forum/forumdisplay.php?f=3)
-   -   Process completed with exit code -1073741502 (http://www.kinook.com/Forum/showthread.php?t=5296)

gmanupnorth 08-27-2014 06:40 AM

Process completed with exit code -1073741502
 
Good day everyone.

I have a run program task in Visual Build that keeps failing as follows:

8/26/2014 2:38:27 PM: Building subroutine step 'Obfuscate'...
"C:\Program Files (x86)\LogicNP Software\Crypto Obfuscator For .Net 2013 R2\co.exe" projectfile=E:\Builds\15\eEye.RetinaCS\Mainline-Release\Sources\Setup\ScrambleTheCode.obproj

Process completed with exit code -1073741502
8/26/2014 2:38:28 PM: Step 'Obfuscate' failed

This is a Run Program Task that calls the Crypto Obfuscate command line exe. Here is the XML snippet from the build file:


-1
0
%OBFUSCATION_EXE_PATH% projectfile=%PROJDIR%\ScrambleTheCode.obproj
1
1
Obfuscate
1
1
GM3oPP48Z+H6auS4/qGvgw==
0
administrator


Any help would be really appreciated.

Gordon

kinook 08-27-2014 07:02 AM

If the process is actually completing its work and returning a spurious exit code, you could ignore that particular code by adding it to the Success exit codes field.
http://www.kinook.com/VisBuildPro/Manual/programtab.htm

You should be able to reproduce the problem outside Visual Build by running a Command Prompt under the Administrator account and creating and running a batch file as described in the 2nd post at http://www.kinook.com/Forum/showthread.php?threadid=438

gmanupnorth 08-27-2014 08:15 AM

Yeah, we were able to reproduce the same error using a batch file

gmanupnorth 08-29-2014 09:42 AM

Process completed with exit code -1073741502
 
Our Build Controller runs as NETWORKSERVICE and the Run Program Task needs to run as administrator and it seems like this elevation fails within the build process.

Not sure how to resolve it......

kinook 08-29-2014 10:05 AM

Does the program really need elevated privileges? Maybe that could be fixed.

Otherwise, try something like elevate.
http://code.kliu.org/misc/elevate/


All times are GMT -5. The time now is 07:22 AM.


Copyright 1999-2019 Kinook Software, Inc.