Kinook Software Forums

Kinook Software Forums (http://www.kinook.com/Forum/index.php)
-   [VBP] Third Party Tools (http://www.kinook.com/Forum/forumdisplay.php?f=3)
-   -   Help with Visual Studio step (http://www.kinook.com/Forum/showthread.php?t=5679)

deramor 08-28-2020 12:08 PM

Help with Visual Studio step
 
Hello,

My build environment was working fine but then I installed the Visual Studio 2015 build tools and now my VS2019 steps are using a different version of MSBuild.

For now, I've overridden the path to MSBuild in the options tab of those failing steps but I wanted to better understand the problem. I don't want to be forced to forever have to implement this workaround.

My question is, how does Visual Build locate the version of MSBuild? I know it has to do with the solution files from posts I've seen on these forums. All of my solution files are created in VS2019 (and were previously working). If I knew the step's logic, I could look in more places (like registry) that could have been modified erroneously.

Thanks for any input.

kinook 08-28-2020 06:35 PM

I sent you some code that will explain this.

Also see https://kinook.com/Forum/showthread.php?t=4500

deramor 08-31-2020 10:29 AM

Thank you. After looking at the code and how the list of potential MSBuild instances was gathered and selected, I eyed your logic with my solution files and found that even though the project standardized on VS 2019, many solutions were made by 2013. This caused your logic to pick something I didn't expect.

Some kind of interaction with the solution and older MSBuild version caused things to not work. Fortunately, I can correct the solution files to correctly target 2019 as intended and everything works fine.

Thanks for helping. I suppose I should have checked my own solutions.


All times are GMT -5. The time now is 03:54 PM.


Copyright 1999-2019 Kinook Software, Inc.