Kinook Software Forums

Kinook Software Forums (http://www.kinook.com/Forum/index.php)
-   [VBP] Third Party Tools (http://www.kinook.com/Forum/forumdisplay.php?f=3)
-   -   Building .Net Web Projects on Windows 2003 (http://www.kinook.com/Forum/showthread.php?t=864)

jaylab 02-04-2005 08:30 AM

Building .Net Web Projects on Windows 2003
 
I have a Visual Build project running on Windows 2000 that builds .Net web projects just fine. I am using the csproj files and not the solution, so I go into the app mappings in IIS and remove csproj. Everything works great. I applied these settings based on other posts I read.

I am now moving my build to run on Windows 2003. The same Visual Build project (working on Windows 2000) gets an error when I try to build my .Net web projects. I have applied the exact same settings as on Windows 2000. The error I am recieving is:

Step default property 'Filename' = 'http://localhost/introspect/searchui/searchui.csproj'
The remote server returned an error: (404) Not Found.

If I try to build from the sln I get the same error:

Step default property 'Filename' = 'C:\Development\5.1 SP1\Source\Web Projects\SearchUI\SearchUI.sln'
Error loading info for project file 'http://localhost/introspect/SearchUI/SearchUI.csproj': The remote server returned an error: (404) Not Found.

If I specify the full path I get and invalid project error:

Step default property 'Filename' = 'C:\Development\5.1 SP1\Source\Web Projects\SearchUI\SearchUI.csproj'
Pre-processing...

Rebuilding configuration 'Release'...
Command: "c:\Program Files\Microsoft Visual Studio .NET 2003\Common7\IDE\devenv.com" "C:\Development\5.1 SP1\Source\Web Projects\SearchUI\SearchUI.csproj" /rebuild Release /project "C:\Development\5.1 SP1\Source\Web Projects\SearchUI\SearchUI.csproj"

Microsoft (R) Development Environment Version 7.10.3077.
Copyright (C) Microsoft Corp 1984-2001. All rights reserved.

Invalid project

I can get the project to compile using the following syntax from the cmd prompt:

devenv.com "C:\Development\5.1 SP1\Source\Web Projects\SearchUI\SearchUI.csproj" /build Release

Is there anything special I need to do on Windows 2003? Can you see where I am going wrong? Any reccomendations to resolve this would be great.

kinook 02-05-2005 07:58 AM

You shouldn't need to do anything special. Check this thread and see if it helps:
http://www.kinook.com/Forum/showthread.php?threadid=843


All times are GMT -5. The time now is 04:44 AM.


Copyright 1999-2019 Kinook Software, Inc.