Kinook Software Forums

Kinook Software Forums (http://www.kinook.com/Forum/index.php)
-   [UR] General Discussion (http://www.kinook.com/Forum/forumdisplay.php?f=23)
-   -   Read-only items are not read-only (http://www.kinook.com/Forum/showthread.php?t=4938)

Nobodo 11-30-2011 02:46 PM

Read-only items are not read-only
 
I copy a lot of emails into UR from Outlook.

Often when a set of instructions in an email need to be changed, I forget that I am viewing an email in UR and just start typing along, correcting the instructions.

UR gladly accepts these changes to the stored email, but then as soon as you go to a different item and then go back to the email, all the work you just did in changing the item is lost.

Shouldn't an item be read-only in the viewer if UR will not store changes to it? This is a situation that allows a loss of data but gives no warning at all that the data will be lost.

Thanks,
Mark.

kinook 11-30-2011 04:48 PM

How are you editing the messages in UR? The MIME viewer doesn't support editing of message content.

Nobodo 12-02-2011 10:36 AM

Quote:

Originally Posted by kinook (Post 19253)
How are you editing the messages in UR? The MIME viewer doesn't support editing of message content.

I did some experimentation with it, and noticed that sometimes the stored emails are readonly and sometimes they are not.

The consistent thing that I found is that if two emails are stored, both as children of the same node, the 2nd email allows you to type away and modify the stored email, but changes are lost when you go to another item.

Steps to reproduce:
  1. Select an email in Outlook (I'm using version 2007 if that matters).
  2. Click the button in Outlook to copy the email to UR.
  3. In the dialog, choose a node where the email should be inserted, and choose the radiobutton for 'Copy', and store the email.
  4. Go back to Outlook and go to a different email.
  5. Follow the same steps to copy this email into UR, making it a sibling of the first email.
  6. The second copied email allows you to modify as you wish, but mods are lost when you leave the stored email.

I commonly have one work item that I copy many emails to, so several emails will be siblings (all children of the same node).

Thanks,
Mark.
UR 4.2b on Win 7 Ultimate 64bit

kinook 12-02-2011 11:10 AM

Again, how are you editing the messages in UR? The MIME viewer in UR doesn't support editing of message content.
http://www.kinook.com/Forum/showthread.php?t=3038

Nobodo 12-02-2011 01:54 PM

I just go into the email stored in UR, and it freely allows me to make any modifications I want to the email just as if it was a text note. Then when I go to another item and back to the stored email, the changes are gone. I guess I don't know what you mean by "how are you editing the messages in UR" - just like any other item.

As to the "how to report problems":
I will go through all those steps when I have time; that won't be today but I can as soon as possible. Are you saying that you cannot recreate the problem by doing the explicit steps I already posted in this thread? I reboot daily, so that isn't an issue, and I just tried creating a new UR database and the problem exists in a brand new database too.

Thanks,
Mark.

kinook 12-02-2011 03:35 PM

I imported two messages from Outlook as siblings. Trying 3 times, with .msg configured to display in the browser (Tools | Options | Browser | File extensions to display in internal browser view), then text editor (Tools | Options | Editor | File extensions to display in text editor), and then MIME viewer (Tools | Options | Documents | File extensions to display in MIME viewer), I was unable to edit the message body of either message.

Nobodo 12-02-2011 05:26 PM

Quote:

Originally Posted by kinook (Post 19260)
I imported two messages from Outlook as siblings. Trying 3 times, with .msg configured to display in the browser (Tools | Options | Browser | File extensions to display in internal browser view), then text editor (Tools | Options | Editor | File extensions to display in text editor), and then MIME viewer (Tools | Options | Documents | File extensions to display in MIME viewer), I was unable to edit the message body of either message.

Under 'Browser' .msg is in "File extensions to display in internal ..."
Under 'Editor' .msg is not in "File extensions to display in text editor".
Under 'Documents' there is nothing at all in "File extensions to display in MIME viewer".
Under 'Documents' .msg is one of many extensions in "File extensions to open stored documents writeable".
Under 'Documents' .msg is not in 'File extensions to edit/view externally".

Thanks,
Mark.

kinook 12-02-2011 10:08 PM

It's Internet Explorer that actually displays the message content when .msg is configured to display in the browser view. IE didn't allow editing of messages in my tests, so I'm not sure what's different there. Maybe try removing .msg from the File extensions to open stored documents writeable option.


All times are GMT -5. The time now is 03:07 PM.


Copyright 1999-2021 Kinook Software, Inc.