Kinook Software Forums

Kinook Software Forums (http://www.kinook.com/Forum/index.php)
-   [UR] General Discussion (http://www.kinook.com/Forum/forumdisplay.php?f=23)
-   -   Large images in text editor not displaying (http://www.kinook.com/Forum/showthread.php?t=5459)

cnewtonne 12-16-2016 01:29 PM

Large images in text editor not displaying
 
Hi there ...

When I produce a screen region copy, it gets pasted much larger in UR. For example, when I take a region copy of a the browser's back button which shows on screen something like 1x1 inches, it gets pasted as 3x3 inches. I believe this had to do with high res. screen.

As long as the image does not exceed a certain size, it gets inserted in UR just fine. If it goes larger, UR no longer displays the image. I only see a large flashing cursor at the side of the image boundary, but the image itself does not show.

Is there an UR configuration where it limits the size of an image (size in inches or bytes)?

Thanks

kinook 12-16-2016 02:06 PM

No, there isn't. This is about the only thing I can think of that might be a factor:

http://www.kinook.com/Forum/showthread.php?t=3086

cnewtonne 12-16-2016 05:21 PM

Wow ...
The post you listed was started by me when I was 10 years younger.

Almost worked, but :) :) it really didn't

When I disbled RefreshOnPasteImage, these large images pasted fine and no longer disappeared. But, once I switched info items, going back to the one containing the large image not longer showed it. This is true even when I do ctrl+s to save it.

In other words, the image shows as long as you don't switch info items. For the smaller images, they always work fine.

Please, keep this on your radar.

kinook 12-16-2016 06:57 PM

Please post or send the info from

http://www.kinook.com/Forum/showthread.php?t=3038

cnewtonne 12-18-2016 09:11 PM

Here's a screen cast showing the issue https://www.dropbox.com/s/9zji6z5jqv...mages.mp4?dl=0

I tried every version of the riched20.dll & all exhibit same behavior.

Ultra Recall Professional 5.2
Copyright 2004-2016 Kinook Software, Inc.
Registered to: XXXX (1-user license)
Windows version: Windows 10 Pro
Install path: C:\Program Files (x86)\UltraRecall
hrs32.dll version 5.0.1.3
hts11.dll version 11,0,2,3
mimepp.dll version 3.0.4
MSPTLS.DLL version 16.0.6925.1014
PolarSpellChecker.dll version 4.0.5.4
RICHED20.DLL version 16.0.6925.1014
SftPrintPreview_IX86_U_20.dll version 2.04
ter16.dll version 16.0.5.0
UltraRecall.exe version 5.2.0.8
unins000.exe version 51.52.0.0

kinook 12-18-2016 09:56 PM

It must be a limitation of the rich edit control itself. In my tests, a full screen shot (1920 x 1080) displays properly, but a double screen shot does have the behavior you describe, and the same thing occurs when opening externally in WordPad.

One option would be to paste a large image as a separate item into the tree -- the internal image viewer does properly display larger images.

Or edit the item externally in Word.

cnewtonne 12-19-2016 09:08 AM

Wordpad 1607 behaves similar to Word and OneNote. No problem showing large images. I can confirm inserting image into its own item, works fine.

The only practical limitation is that I need these images to stay within the text for demo purposes. Also, having to do edit externally assumes the user of UR needs also to purchase MS Word for such a simple functionality.

I had hoped to solve this problem. I'll keep an eye on this thread in the future. I will also continue to invistigate.

Thanks & happy holiday.

kinook 12-19-2016 09:26 AM

4 Attachment(s)
I'm not sure what size your images are, but my tests give similar behavior for UR and WordPad on Windows 10.1607.14393.576).
Images below are for a 1920 x 1080 single screen shot in UR & edited externally in WordPad,
then a dual screen shot 3840 x 1080 in UR & WordPad.

Ultra Recall Professional 5.2
Windows version: Windows 10 Pro
Install path: C:\Program Files (x86)\UltraRecall
riched20.dll version 5.50.99.2050
UltraRecall.exe version 5.2.0.8

cnewtonne 12-19-2016 09:45 AM

On the Surface Book, print screen produces 3000x2000 image. I could not figure out a way to have it capture images at a lower resolution.

This image pastes successfully in WordPad. It appears, though. WP scales it down which is OK for my use case.

UR editor, for some reason, chokes on it.


Thanks

kinook 12-19-2016 10:12 AM

Images that large could also balloon the database size and slow down processing. You may want to resize them before importing just for those reasons, which would also avoid the large image display issue.

cnewtonne 12-19-2016 10:50 AM

Probably, true.

But the fact that UR can paste it 'ctrl+v' with focus on tree as 'bmp' suggests that it can do it. Looks like this is another annoyance of the riched20 dll.

How did you get UR to open externally with Wordpad instead of Word?

Thanks

kinook 12-19-2016 10:58 AM

Make it the default program for .rtf files in Windows, or use Ctrl+E, 'Open with' menu.

https://office-watch.com/2016/changi...way-from-word/

http://kinook.com/UltraRecall/Manual...externally.htm

cnewtonne 12-20-2016 09:11 AM

I started having this problem after upgrading to Surface Book. Using the Surface Pro for the last 2 years, I never had issues.

Unfortunately, I rely heavily on images for scanned docs, whiteboards, faxes in my line of work. UR is now failing to save them most of the time.

:(


All times are GMT -5. The time now is 07:33 PM.


Copyright 1999-2019 Kinook Software, Inc.