Kinook Software Forums

Kinook Software Forums (
-   [UR] General Discussion (
-   -   Editor does not scroll using Surface Pro touchpad gesture (

cnewtonne 05-19-2016 03:14 PM

Editor does not scroll using Surface Pro touchpad gesture
I use UR on an SP3. It allows using 2 finger gesture to scroll. It works in most apps. It does not in UR. When I attempt to scroll editor pane, the scroll bar flickers up & down but does not move. My only option is to click and drag the scroll bar. This is significant hit to the user experience.

It works fine in the data explorer pane, though.

Where is this behavior stemming from?

Thank you

kinook 05-19-2016 03:30 PM

Does it work in WordPad? You might try different versions of the MS rich text editor to see if one works better.

cnewtonne 05-23-2016 03:46 PM

Scrolling works fine as expected with RICHED20.DLL version 16.0.6828.1016. It also works fine with wordpad on windows 10.

It did not work with anything below this release e.g. riched20.dll version 14.0.4750.1000. The workaround is to to follow every scroll with a left click. Looks like mouse cursor has to follow the scroll all the time.

Ultra Recall Professional 5.2
Copyright 2004-2016 Kinook Software, Inc.
Registered to: XXXX (1-user license)
Windows version: Windows 10 Pro
Install path: C:\Program Files (x86)\UltraRecall
hrs32.dll version
hts11.dll version 11,0,2,3
mimepp.dll version 3.0.4
msptls.dll version 15.0.4420.1017
PolarSpellChecker.dll version
RICHED20.DLL version 16.0.6828.1016
SftPrintPreview_IX86_U_20.dll version 2.04
ter16.dll version
UltraRecall.exe version
unins000.exe version
Database filename: xxxxx
Database version: 4.0.1 [FTS]

cnewtonne 05-24-2016 12:40 PM

I switched to using RICHED20.DLL version 16.0.6828.1016 for now. Too early to tell, but hope it works.

If you run into hanging issues, specially, when pasting large text, disable 'check spelling as you type'. Looks like this is a known issue, hoping it gets fixed someday :)

Thanks for the great support.

cnewtonne 05-25-2016 11:19 AM

Spoke to soon.

The RICHED20.DLL version 16.0.6828.1016 crashes UR. With this file in UR install folder, it won't even launch. I had to revert back to the 14.* release :(

Not sure why and I hope UR can be updated to utilize latest release of this dll.

If willing, I'm available to work with you to try to resolve it. IMHO, there is no excuse for UR not to respond to such fundamental user experience expectation to scroll its editor via the trackpad. Surface Pro & Book are modern and flagship MS devices. Why not make UR compatible ?!


kinook 05-26-2016 04:37 PM

1 Attachment(s)
Working for me with v16.0.6925.1014. Maybe you are using the 64-bit DLL.

cnewtonne 05-26-2016 07:37 PM

1 Attachment(s)
Mine was a little older. But, I believe it may have not worked because I pasted it in the UR install folder without mstpls.dll file. It worked after downloading the zip archive you posted here (v16.0.6925.1014 (installed with Office 2016))

I was able to open UR with no crashes, browse some items, and scroll long text items. All good for now. I'll confirm after a full day use tomorrow.

All times are GMT -5. The time now is 05:57 AM.

Copyright 1999-2019 Kinook Software, Inc.