Kinook Software Forums

Kinook Software Forums (
-   [UR] General Discussion (
-   -   URp prevents spreadsheet from opening in Excel (

martym 10-12-2007 09:39 AM

URp prevents spreadsheet from opening in Excel

I'm using URp version 3.2.5. I have a spreadsheet data item that is stored internally in UR open in the UR internal browser. Using Windows Explorer, I double clicked on a different spreadsheet to open (externally) in Excel. Excel opened but no spreadsheet was displayed. I tried several times, closing Excel each time but had the same result. Then I changed UR focus to a different data item that was NOT a spreadsheet. After doing that, reclicking on the other spreadsheet in Explorer opened the new spreadsheet in the external Excel. This is repeatable.

Anyone else see this kind of behavior? I did a search on "steal focus" in the forums but nothing came up.


kinook 10-12-2007 11:40 AM

I'm seeing that too, but it's actually Excel (the instance hosted within UR) that is preventing the external Excel instance from getting focus/loading the file. It sounds like an Excel bug or "feature".

jjinwi 10-12-2007 12:52 PM

I have the same problem too.

It only happens with Excel... not word or ppt.


Cris Tontchev 10-15-2007 02:13 PM

Same here.

jwleonard 09-03-2010 08:03 AM

What happened to the EXCEL problem. I having the same problem. Back to topic please.

ashwken 09-03-2010 09:11 AM

Running UR Pro 3.5e, Excel 2003 SP-3

Appears to depend on whether or not the stored file is being displayed in the Detail Pane, which as Kinook mentioned "it's actually Excel (the instance hosted within UR) that is preventing the external Excel instance from getting focus/loading the file".

Select the Stored Excel Item and it opens in the UR detail Pane, with focus on the item in the Data Explorer do a Ctrl-J to open the file externally. The Excel file opens externally in Excel as expected, close Excel.

Now back in UR the Stored Excel Item is still selected in the Data Explorer, but the Detail Pane is showing the three choices for editing the file. From Windows Explorer I can launch an Excel file.

Course, as soon as you move focus off the Item, and come back it's displayed in the Detail Pane and you're back to square one.

You could remove the following reference (.xls) from Tools | Options | Browser - File extensions to display in internal browser view, and resign yourself to opening the Excel file via Ctrl-J.

Course the text contents of the spreadsheet are still going to display in the Detail Pane and can be a bit disconcerting, but they are not editable, regardless of the settings found in Tools | Options | Document - File extensions to open stored document writable.

None of which is a solution, simply what I've found.

edit: spelling

armsys 09-03-2010 06:19 PM

No one has mentioned about UR 4.2. Does it imply that it isn't an issue in UR 4.2?

All times are GMT -5. The time now is 02:31 AM.

Copyright 1999-2019 Kinook Software, Inc.