Kinook Software Forums

Kinook Software Forums (
-   [UR] General Discussion (
-   -   Problem importing rich text from clipboard (

ktibor 10-19-2019 09:06 AM

Problem importing rich text from clipboard
When the clipboard is filled from any simple text editor, after the command "Ultra Recall (any.urd) /importclip", the new item is created with correct item title (first line of text) but the item text area in Item Details pane remains empty.
When the clipboard is filled from an urd file's item text or from a browser window, the import operates correctly.
Various Options/Import settings are ineffective.
This is a new phenomen in UR6.

Tibor Kovacs

cnewtonne 10-22-2019 03:11 PM

I noticed it too, but I do not use command line. It started happening in version 6. Some html content, when pasted into the tree, it creates the child with correct name, but the item text editor remain empty.

Have not had the chance to troubleshoot it any further yet.


kinook 10-22-2019 03:45 PM

There was a problem with importing rich text from the clipboard, which is fixed in the latest download (

ktibor 10-23-2019 02:46 AM

Thank You. I updated to Importclip problem solved but after update two new problems have arisen.

1. Background colors of rtf items, created by background-coloring the text template in MS Word, have disappeared.

2. Internal links between items, pasted into rtf text, appear incorrectly, not only the blue item title, eg.:
Test_item_ for_internal_link
Blue, underlined but not sensitive to mouse click.
The database was not corrupted, and remained intact even after the two issues occurred, checked via UR5.

ktibor 10-23-2019 03:27 AM

Additions to my previous post about two issues

My environment:
Windows 10 1903 up to date, Hungarian settings
MS Office 2007 32 bit Hungarian version.
This environment and UR5 has worked seamlessly so far.
Ultra Recall Professional 6.0
Copyright 2004-2019 Kinook Software, Inc.
Registered to: Tibor Kovacs (1-user license)
Windows version: Windows 10 Home N
Install path: D:\Utils\UltraRecall_6
hrs32.DLL version
HRW15.DLL version
HTS21.DLL version 21,0,0,0
HTW21.DLL version 21,0,0,0
msptls.dll version 15.0.4420.1017
msvcr100.dll version 10.00.40219.325
PolarSpellChecker.dll version
riched20.dll version 15.0.4420.1017
SftPrintPreview_IX86_U_20.dll version 2.07
SftPrintPreview_x64_U_20.dll version 2.07
TER26.DLL version
TEW26.DLL version
UltraRecall.exe version
unins000.exe version
C:\WINDOWS\SYSTEM32\RichEd20.dll version
Database filename: D:\_INFO\nettalalat.urd
Database version: 4.0.1 [FTS]

kinook 10-23-2019 08:21 AM

It appears that you have a mixture of 32-bit and 64-bit DLLs in the installation path.

1) Uninstall UR
2) Delete the folder D:\Utils\UltraRecall_6
3) Download from
4) Reinstall.

ktibor 10-23-2019 11:23 AM

After reinstalling it is perfect. Thank You. I was careless.

All times are GMT -5. The time now is 10:07 PM.

Copyright 1999-2019 Kinook Software, Inc.