Kinook Software Forums

Kinook Software Forums (http://www.kinook.com/Forum/index.php)
-   [VBP] Third Party Tools (http://www.kinook.com/Forum/forumdisplay.php?f=3)
-   -   SignTool Error: SignerSign() failed when run from VBP (http://www.kinook.com/Forum/showthread.php?t=5588)

dhollman 05-02-2019 10:18 AM

SignTool Error: SignerSign() failed when run from VBP
 
I have recently started using a code signing certificate which is housed on a USB dongle.

Previously when using a PFX file for the certificate I could sign code without issue from VBP. But now I am running into an error:

Code:

Done Adding Additional Store
Error information: "Error: SignerSign() failed." (-2147023673/0x800704c7)
SignTool Error: An unexpected internal error has occurred.


This occurs both when using the Sign Code action, or even just running signtool in a Run Program action. (Same error, either way).

If I run signtool manually on the command line (not using VBP) there is no error.

What has to happen when signtool runs is that some local software interfaces with the USB dongle and prompts you for a password before signing can take place. This works from the command line but does NOT occur when running from VBP. This is likely the cause of the mysterious error above.

I'm not sure what to do to get this to work from VBP...

Thanks

kinook 05-02-2019 02:17 PM

You have to provide a password in a UI prompt from an automated build? Yuck.

Maybe try checking 'Use interactive desktop' on the Advanced tab, but note the caveats at https://kinook.com/VisBuildPro/Manua...dvancedtab.htm.

Another possibility might be to call from a Run Program action and uncheck 'Hide application window' on the Program tab.


All times are GMT -5. The time now is 01:56 AM.


Copyright 1999-2019 Kinook Software, Inc.