Kinook Software Forums

Kinook Software Forums (
-   [VBP] General Discussion (
-   -   WebLauncher and Perforce (

scoffman 08-22-2018 03:36 PM

WebLauncher and Perforce
I read the documentation related to the web interface available for VB Pro. After a bit of time, I was able to get the WebLauncher up and running on the build machine. And I was able to invoke the build script from a different machine using the interface. Things were looking good.

Then the script hit the pull from Perforce and it returned an error about the username or password. The script contains the information for the workspace, server, port, username, and password. I have no issues running the step via the VBP GUI. But when invoked via the web interface, any action related to Perforce returns the same error.

An example of the step is a get latest with Perforce. Nothing fancy, just a simple step passing the data via script variables (in the script, not the WebLauncher) and pulling a project.

Any suggestions?

kinook 08-22-2018 09:13 PM

What is the error message? Is the identity specified in web.config as described in Default.aspx.cs? Maybe try the LOGON_WITH_PROFILE option.

scoffman 08-22-2018 09:44 PM

The error message returned in the script is "Failed to create process: Logon failure: unknown user name or bad password."

The username and password were implemented into the web.config. The machine is a domain machine so the web.config contains the credentials for the domain user. The user is an admin on the machine. When accessing the build machine via RDP, we use the same credentials.

I took your suggestion and modified the code to use the LOGON_WITH_PROFILE option. Rebuilt and re-deployed but the error is still being thrown.

kinook 08-22-2018 11:17 PM

You might try specifying the domain in that parameter or prefixing the domain on the username parameter as user@domain and specifying null for the domain parameter.

scoffman 08-23-2018 09:13 AM

I had domain\username in the web.config, which worked until the script hit Perforce. I took your suggestion and modified the code and attempted a variety of different scenarios. Unfortunately, none of the changes eliminated the error with Perforce.

I tried and passing null as the domain parameter. When doing so, I wasn't able to connect to the weblauncher. When I revert back to domain\username, I am able to connect to the weblauncher.

As I had been attempting to use a domain user, I decided to try a local user. So I created a local user and made the user an admin. I passed the credentials for the local user. And I was able to bypass the Perforce error.

It would appear to be an issue with CreateProcessWithLogonW and Perforce using a domain user.

I did come across an article from a few years ago that described a similar situation. One poster mentioned the user might not have access to the share, even if the same credentials are passed.

All times are GMT -5. The time now is 11:29 PM.

Copyright 1999-2019 Kinook Software, Inc.