Kinook Software Forums

Kinook Software Forums (http://www.kinook.com/Forum/index.php)
-   [VBP] Third Party Tools (http://www.kinook.com/Forum/forumdisplay.php?f=3)
-   -   NUnit 2.4.1. & Users (http://www.kinook.com/Forum/showthread.php?t=3352)

DwayneGreen 12-27-2007 01:56 PM

NUnit 2.4.1. & Users
 
When I am running a nunit project within visual build professional 6.5, I am unable to get the nunit project to build. I get an error - "Failed to create process: The system cannot find the file specified."

However, when another developer who is located 600 miles away runs the same project, the nunit project is able to build sucessfully.

We are both accessing the same machine which is using Windows XP through remote desktop and we both have the exact same permissions "Build\Administrator".

Does anyone know how to fix this?

DwayneGreen 12-27-2007 01:57 PM

I forgot to add that I checked the NUnit Assemblies in the file system and they are pointing to the correct dlls.

kevina 12-27-2007 07:34 PM

Something must be different in the environment of the two workstations, please try checking the "Log command-line constructed for call" checkbox on the Options tab of the NUnit step, then execute this command-line manually from a cmd prompt to determine what is not working properly on the workstation receiving the error.

Without more info I would guess that nunit-console.exe is not found by Visual Build Pro, perhaps due to a path not being in the Path environment variable or because NUnit is installed to a non-standard location?

DwayneGreen 12-28-2007 11:41 AM

I put the NUnit environment variable path in and this seemed to fix the problem. I think what happened was the other developer had his profile setup with the NUnit path already in the environment variables.

Thank you for helping.

Feature Request: Visual Build Professional states what file it is looking for when the specified file is not found.


All times are GMT -5. The time now is 04:49 AM.


Copyright 1999-2019 Kinook Software, Inc.