Kinook Software Forums

Kinook Software Forums (https://www.kinook.com/Forum/index.php)
-   [UR] General Discussion (https://www.kinook.com/Forum/forumdisplay.php?f=23)
-   -   enhanced full text search does not work correct (https://www.kinook.com/Forum/showthread.php?t=4363)

hartmut 01-07-2010 07:00 AM

enhanced full text search does not work correct
 
I have enabled full text charge und have to state the the match whole function does not work correctly even after having compacted and repaired database.

For example I search for Lauch and I will receive in the resul list all items containing Knoblauch and Knoblauchzehe etc. i.e. all words which contain the search word lauch
My version of UR is 4.1b and the OS ist Windows XP
Hartmut

kinook 01-07-2010 08:18 AM

http://www.kinook.com/Forum/showthre...?threadid=3038

hartmut 01-07-2010 09:25 AM

I have sent the details to support@kinook.com.
I think the problem comes from the pdf-files imported as you will see from the database sent.
Hartmut

kinook 01-07-2010 12:40 PM

1 Attachment(s)
Each one of the matching files has the word 'lauch' in it. See attached screen shot.

hartmut 01-07-2010 02:29 PM

If you look at 000107rezepte.pdf and 001006rezepte.pdf, in the database I sent to you, the word lauch appears not as the word lauch itself it appears only composed as Knoblauch or Knoblauchzehen. The word Lauch itself exist only in the item 000204rezepte.pdf

A search with lauch should only result in the document containing lauch only i.e. 000204rezepte pdf.

A search with lauch* should result in 000204rezepte.pdf too as there is the word Lauchstange

A search with *lauch* should show as result all documents for Lauch, Lauchstange and Knoblauch

A search with *lauch should show all documents containing Knoblauch.
When you search for lauch all 3 pdf are shown in the result window, but 000107rezepte.pdf and 001006rezepte.pdf do not contain Lauch but Knoblauchzehe and Knoblauch.
I refer in this matter to following phrase of teh helpfile of UR
If full-text search enhancements are enabled, matches are whole word by default. To match a partial word, add a * at the end of the word (i.e. test*).
In the pure text item the search works well, it concerns only the pdf files.
Hartmut

hartmut 01-07-2010 02:41 PM

Sorry, may be I have found the problem,
the documents are found as in these documents the word is composted but the two parts of the word are hyphenated at the end of the line?
If I have a document with ownership and one with owner-ship the search for ship will result in the document with owner-ship.
Does any one have an idea to avoid these results?


Hartmut


All times are GMT -5. The time now is 02:39 AM.


Copyright 1999-2021 Kinook Software, Inc.