Kinook Software Forums

Kinook Software Forums (
-   [VBP] General Discussion (
-   -   Downloading http url with username & password? (

Rogier 09-28-2009 09:45 AM

Downloading http url with username & password?
1 Attachment(s)
I need to download a HTTP url, and the server requires a username and password. However it does not offer https access, only http, so the 'Security' tab of the HTTP action is set to 'None'. (I'm mentioning this because I'm not sure if the username & password authentication are also used when using *no* security protocol?)

I've isolated a test case, see attachment. I'm trying to download this test url:
(username = user, password = example)

The .bld says "Error getting file: The specified resource cannot be found (Not Found)" although it works fine in my browser.

I'm probably not using the HTTP action correctly, what am I doing wrong?

kinook 09-28-2009 10:01 AM

1 Attachment(s)
That works ok here using VBP 7.2 and the attached project.

9/28/2009 7:57:50 AM: --------------------Starting Build: 'http.bld'--------------------
9/28/2009 7:57:50 AM: Building project step 1 - Project steps...
9/28/2009 7:57:50 AM: Building project step 2 - HTTP...
Connecting to HTTP server '' on port 80
C:\Temp\cat.jpg <- /test/cat.jpg
9/28/2009 7:57:51 AM: Build successfully completed.

Rogier 09-28-2009 10:46 AM

1 Attachment(s)
Hmm strange, I just updated to 7.2 and tried again, but still no go :(

Actually, I tried downloading a link that doesn't require a username/password (see example2.bld in attachment), i.e. just a plain normal http download, and even that gives me the same problem!

Dunno if it helps, but I've set the logging of the HTTP action to 'All' and tried again, see the results attached. Any idea?

(PS. It's not just this test site or server, I've tested with several different URLs as well)
(PPS. Just to be sure, I also disabled my firewall and tried again: no difference unfortunately)

kinook 09-28-2009 10:56 AM

Did you try my .bld file? One difference I noticed is that the URL field in yours includes the protocol+domain (i.e., It should include only the filename on the server (i.e., /cat.jpg).

Rogier 09-28-2009 11:26 AM

Oh, sorry.. *feeling stupid* Yes I did try your .bld now, and apparently the protocol+domain vs filename difference did the trick :)

Thanks a lot for your great service!

Japster24 09-21-2011 01:53 PM

Just wanted to say thanks for the sample kinook. As always, you guys just rock!

All times are GMT -5. The time now is 07:40 AM.

Copyright 1999-2022 Kinook Software, Inc.