Kinook Software Forums

Kinook Software Forums (http://www.kinook.com/Forum/index.php)
-   [VBP] Third Party Tools (http://www.kinook.com/Forum/forumdisplay.php?f=3)
-   -   Controlling which version of Visual Studio VBPro Uses (http://www.kinook.com/Forum/showthread.php?t=1649)

mweinberger 03-27-2006 01:55 PM

Controlling which version of Visual Studio VBPro Uses
 
Hi All,

My build machine has both VS2003 and VS2005 installed. I'm trying to build a C++ based solution using VBPro, but the product tries to use VS2003 to build and not VS2005 as it should.

I set one of the macro variables to VS2005 as you can see below, but that didn't do anything for my current problem. Which other variable/macro should I touch and to what?

Thanks in advance,

Martin


Microsoft Visual Studio .NET command-line build tool
"%DEVSTUDIO_NET_DIR%\Common7\IDE\devenv.com"


Microsoft Visual Studio .NET installation path
%MSVSTUDIO_2005%



Microsoft Visual Studio 2003 root folder
C:\Program Files\Microsoft Visual Studio .NET 2003


Microsoft Visual Studio 2005 root folder
C:\Program Files\Microsoft Visual Studio 8

kinook 03-27-2006 02:16 PM

The Make VS.NET action parses the solution/project file to determine the correct version of devenv/msbuild/vcbuild to invoke. You can override this via the 'Override...' field on the Options tab:
http://www.visualbuild.com/Manual/vsnetoptionstab.htm

But please ZIP and post or send:
1) The info from Help | About | Install Info
2) The .bld file used to build
3) A build log file
4) The .sln file and project files being built (no source code files)

as that shouldn't be necessary.

mweinberger 03-27-2006 02:37 PM

Here's the zip file
 
1 Attachment(s)
Evidently, the Make VS.Net step didn't parse the solution file correctly to determine the version number.

kinook 03-27-2006 02:49 PM

In the .bld file you posted, the failing step named 'Build - vzDLUpgrade.sln - Debug Compile' is configured to use %7.1_compiler% (which expands to 'C:\Program Files\Microsoft Visual Studio .NET 2003\Common7\IDE\devenv.com') in the previously mentioned Override field, which will override the default parsing of the .sln file for the version information. After I cleared out that field, it built the solution using MSBuild as expected (running on a box w/ VS2003 & 2005 installed).

mweinberger 03-27-2006 04:09 PM

Awesome Response!
 
Thank you!!!!!!

I didn't even see that line there. I'm not even sure why the build engineer before added that line. Thanks for pointing that out. Everything builds nicely, except for the get history error, which you or someone else said to contact Microsoft on. :'(

Thanks again,

Martin :)


All times are GMT -5. The time now is 05:19 PM.


Copyright 1999-2019 Kinook Software, Inc.