Kinook Software Forums

Kinook Software Forums (
-   [VBP] Third Party Tools (
-   -   Installshield DevStudio 9.0 SP 1 (

athompson 05-13-2004 05:46 AM

Installshield DevStudio 9.0 SP 1
At the end of my Visual Build Professional project I'm trying to package the software by calling Installshield DevStudio. The packaging works correctly with zero errors and warnings reported by Installshield, but Visual Build Pro shows that the project step has Failed.

Any idea what I'm doing wrong ?

Having looked in the log I notice the following :

Process completed with exit code -1073741819
13/05/2004 10:22:11: Step 'Build Client Installshield package' failed
13/05/2004 10:22:11: Build ended.

Installsheild seems to return -1073741819 as a return code even though the packaging worked without error.

Perhaps I need to change the Installshield project slightly, but I don't know what needs to be changed.


kinook 05-13-2004 11:01 AM

VBP captures the exitcode of every process it launches, and by convention a 0 exitcode indicates success and a non-zero code failure, so it's just reporting what it sees. First, verify that the same occurs outside of VBP. To do that:

1) check the 'Log the command-line...' checkbox on the Options tab of the InstallSheild action
2) build the step
3) Copy the logged command-line from the Build View
4) Open a text editor and create a new file in the form

echo exitcode = %ERRORLEVEL%

saving as c:\test.bat

5) Open a Command Prompt and type c:\test.bat

If the same exitcode is displayed, you'll need to open a support incident w/ InstallShield to detemine why it's returning a non-zero exitcode when it succeeds. If not, create a reproducible test case and send it to

One workaround would be to mark the step to ignore failure.

Nancy 06-15-2004 09:52 AM

Did anyone ever figure this problem out? Is it an Installshield problem? thanks.


kinook 06-16-2004 12:04 AM

It would appear so. You can verify by following the steps listed above.

tdc 07-08-2004 11:06 AM

Same Error
I am seeing the same thing with Vbuild 5.3 and IS 8.0sp2. The build of the merge module works fine within the IS ide. It also builds fine from the command line in a batch file using your your test.

The merge module built within the build script just fine until I added a .net component into the merge module. That's when the error started.

But since I only get the -1073741819 error with the build script, it looks like this is a Vbuild problem.

Also, trying to run the bat file from a "Run Program" step also results in the error "Unexpected error occurred"

Shelling the bat file through a VBScript step does work; however.

kinook 07-08-2004 08:32 PM

So the batch file reports a different exitcode than VBP? That seems unlikely, but if so, send/post a reproducible test case (the IS script and .bld file performing the build) and we'll take a look.

To execute a batch file from VBP, prefix the command with '%DOSCMD% call '.

morlajb 01-24-2006 11:29 AM


I got the same errorcode while VC6 project is finish.

"Process completed with exit code -1073741819"

I think that the problem is in the visual build , because I didn't get it when I compile with MSDEV.

I can't build a test case for you , because it's NOT happend all the time. but when I 'cut' my project into

kinook 01-24-2006 11:55 AM

Please re-read the second post in this thread. See for a workaround.

All times are GMT -5. The time now is 03:02 PM.

Copyright 1999-2019 Kinook Software, Inc.