Kinook Software Forums

Kinook Software Forums (
-   [VBP] Third Party Tools (
-   -   Redirection not working for Curl command (

paxil 06-08-2015 11:14 PM

Redirection not working for Curl command
I am attempting to write the output of a curl command to a file and it is not working when executing through my VBP step (Run Command step), but it works fine when I manually run it from command prompt window.

This is an example of what I'm trying to execute:

curl.exe -k -x -H "Content-Type: application/json; charset=UTF-8" -X PUT --data-binary "{\"password\":\"\"}" https://%HOST_URL%/api/authenticate > E:\Temp\%ENVIRONMENT%\token.txt

I also tried the "read program output from file" and that does not work either. Currently I have it set to standard output when running the above command.

I'm using VBP 8.6. Is this a bug? Can anyone assist?

kinook 06-08-2015 11:21 PM

See the first note at

paxil 06-09-2015 01:56 AM

Thanks! That worked perfect.

All times are GMT -5. The time now is 03:36 PM.

Copyright 1999-2019 Kinook Software, Inc.