Kinook Software Forums

Kinook Software Forums (http://www.kinook.com/Forum/index.php)
-   [UR] General Discussion (http://www.kinook.com/Forum/forumdisplay.php?f=23)
-   -   minor url bug (http://www.kinook.com/Forum/showthread.php?t=5047)

seanferns 07-13-2012 04:30 AM

minor url bug
 
when pasting urls contains bracket characters "{" and "}" they are converted to backlash "\" and makes the url invalid. The workaround is to manually type %7B and %7D.

kinook 07-13-2012 06:36 AM

Not sure where the URL came from, but I don't believe curly braces are valid in a URL, and they should have been encoded.
http://stackoverflow.com/questions/6...e-curly-braces

seanferns 07-13-2012 06:51 AM

The URL is to tasks in MLO. See page 28 here: http://www.mylifeorganized.net/downl...7s%20Guide.pdf

I would expect UR to encode the URL as per the RFC.

kinook 07-13-2012 08:14 AM

I would expect MLO to encode the URL.

seanferns 07-13-2012 03:08 PM

Touché. I have raised the issue with them. The thing is, in UR if I enter a link with a space/plus/equal sign in it, it does not get encoded to %20/%3D/%2BF unlike firefox/IE yet it changes { and } to \ so it looks like it is trying to do something to the URL but unsuccessfully.

kinook 07-13-2012 06:31 PM

I follow you now. I believe you're referring to the URL when inserting a hyperlink, not when importing a page. Yes, I am seeing that behavior and have flagged it for investigation.

kinook 07-25-2012 05:43 PM

This is fixed in the latest download at http://www.kinook.com/Download/UltraRecallProEval.exe (UltraRecall.exe 5.0.0.1 in Help | About | Install Info after installing).

seanferns 07-26-2012 12:48 AM

Wow. That was quick. There is still one minor problem though.
Try this:
1. Insert hyperlink
2. In Text field type: test
3. In File/URL type (with the quotes): http://www.google.com.sg/#hl=en&q="ultra recall"
4. Click OK
5. Right click on the hyperlink. (doesn't look right)

seanferns 07-26-2012 08:28 AM

One more thing is that there is a noticeable performance degrade with the new version when moving from item to item with the new version. I reverted to the old version and found that the performance to be better. Click on items which have children which are external file links has the most noticeable delay.
I have SelChangeDelay and Synchronous set to zero so something else is going on.

kinook 07-26-2012 12:03 PM

The double quote problem is fixed in the latest build (5.0.0.2). I don't know what could cause a slow down and I'm not seeing one here, although I wouldn't recommend using a SelChangeDelay of 0.

seanferns 07-26-2012 12:09 PM

Thanks. I'll try it out. What sort of behaviour could be attributed to the SelChangeDelay of 0 ?

kinook 07-26-2012 12:15 PM

It could make UR respond more sluggishly -- without a delay, if you want to scroll several items in the tree (i.e., holding down arrow up/down or page up/down, typing to choose an item, etc.), each item scrolled past will load before moving to the next item.

seanferns 07-27-2012 02:55 AM

Works great. Thank you. As for the performance issue, I am not quite sure what's causing it. After playing with UR for a while it seems that whenever I click on a folder display a directory subsequent navigation is slow. Raising the priority of the process seems to help a bit. Thanks again.


All times are GMT -5. The time now is 04:08 PM.


Copyright © 1999-2019 Kinook Software, Inc.