Kinook Software Forums

Kinook Software Forums (
-   [VBP] General Discussion (
-   -   VBP is freezing (

teognost 07-13-2012 10:20 AM

VBP is freezing
2 Attachment(s)
I used to have this problem on another machine ( but now it appears on a new machine (OS installed approx 1 month ago)
Basically the build remains frozen at some random steps (run program,send email,zip files),nothing is written in the log anymore,when I look in Task Mgr I see the VBP process and the child process if it is the case (e.g msbuild.exe) ,by killing the child process the build still remains frozen.
Usually the builds are ran through VisBuildCmd.exe silently from Scheduled Tasks,I tried even to lunch them by VisuildPro with usei interface -in this case I got a white screen and process appears as not responding (see the attachment).
I tried to reproduce this issue but it still appears randomly,not every time.
However I noticed the build freeze appears only when I have multiple (3-4) builds running in the same time (from different folders).
In this case -1 or 2 builds remains frozen always ,the rest are finished ok.
But the necessary build time is increased quite substantial,the builds are very slow-maybe this is causing the freeze ,not sure.
It is important to solve this issue as it happened we had to do some urgent build and when checked if finished -it appears as still running because it was frozen.
I implemented the steps from here:
but did not help.
Even if the hanging step is configured to finish after some time -this does not happen ,it still remains frozen.
This machine is Win2k8 X64 ,4 GB of RAM ,Intel Xeon 3320@2.50 Ghz 2.49 Ghz
VBP installed is :
Visual Build Professional 8.0 (x64)
I created even some dump file for frozen VBP process,I can send it to you if you think it is needed.

kinook 07-13-2012 01:41 PM

2 Attachment(s)
Testing on a Windows 2008 R2 x64 VMWare guest w/ Visual Build Pro v8.0 x64, we built 6 simultaneous instances (3 running VisBuildCmd via scheduled task, 3 running VisBuildPro launched interactively) of the attached project for several hours and could not reproduce any freezing. We would need more details to be able to reproduce the problem here (see

teognost 07-13-2012 07:07 PM

I will try to run your project on my build machine to see if it will freeze.
I am in holiday for 3 weeks so I will get back to u afterwards -unless some emergency will appear in the meantime

teognost 08-20-2012 07:16 AM

On Friday I sent to a zip file ( containg a VBP project that always gets frozen,I tried it on 3 different machines.

kinook 09-03-2012 09:19 PM

On the slow/hanging machines, try setting Tools | Application Options | Advanced | Maximum step output macro length to something other than 0 (the default is 1048576). Also remove or change any script code like this in your project(s):

Application.Options.MaxStepOutputLength = 0
Since the output macro value is stored in memory, and your project generates a lot of output, the 0 value (unlimited) on the problem machines could consume a lot of memory and severely degrade build performance.

Or, modify the 'Parse the difference file -looking for changes other than version' step to not generate so much log output.

teognost 09-07-2012 10:17 AM

Tried your suggestion -it works ok now,not freezing anymore,tks!
I hope this settingwill elliminate the other freezing issues I have with other builds ,will test it now.
But I have a step where a program is ran (Run Program)-I need to write the output of the step to some file.
Before I used to implement a step script like:
Sub vbld_StepDone()
where i write the LASTSTEP_OUTPUT to a file.
Now I will have a partial output in LASTSTEP_OUTPUT but I need all of it to be written in that text file -how can I do it?

kinook 09-07-2012 10:42 AM

change the Command to

%DOSCMD% original command here >c:\path\to\file.ext

teognost 09-07-2012 11:54 AM

when running normally works fine:
"c:\Program Files (x86)\Installshield\StandaloneBuild9SP1\IsSABld.ex e" -p "D:\Builds\ffng\Install\WEB\WEB.ism" -r "Release 1" -c COMP -o "c:\Program Files (x86)\Common Files\Merge Modules"

when adding the DOSCMD it fails:
C:\Windows\system32\cmd.exe /C "c:\Program Files (x86)\Installshield\StandaloneBuild9SP1\IsSABld.ex e" -p "D:\Builds\ffng\Install\ WEB\NG WEB.ism" -r "Release 1" -c COMP -o "c:\Program Files (x86)\Common Files\Merge Modules" >"D:\Reports\BuildsOutput\WEB.ism.txt"
'c:\Program' is not recognized as an internal or external command,
operable program or batch file.

Process completed with exit code 1
9/7/2012 5:53:11 PM: Step '1169 - Build current project' failed

kinook 09-07-2012 12:13 PM

teognost 09-07-2012 12:29 PM


Originally Posted by kinook (Post 19908)

wow,tks a lot,did not think about it
now the output is redirected ok to the text file

All times are GMT -5. The time now is 04:47 AM.

Copyright 1999-2019 Kinook Software, Inc.